Incentives for External Recruitment Requests
Resolved

The issue has been resolved and incentive systems for external participants are now fully operational.

Tue, May 6, 2025, 06:19 PM
(1 week ago)
·
Affected components

No components marked as affected

Updates

Resolved

The issue has been resolved and incentive systems for external participants are now fully operational.

Tue, May 6, 2025, 06:19 PM

Investigating

We're currently investigating reports of issues incentivizing participants on studies with external Respondent participants. Our team is actively working with Respondent to resolve this as quickly as possible. We'll update this page as soon as we have more information to share.

Mon, May 5, 2025, 05:08 PM(1 day earlier)